March Kids

Our spring kidding season is underway, and we’re off to a shaky start.

Fannie was the first to kid. A first-time Mama who almost died last winter, she’s a strong healthy doe now, but the least-tame goat in our herd. She repays my saving her life last year by running from me whenever I’m around.

On Friday I saw her out in the pasture in labor. After giving her plenty of time to kid I went to check on her, finding her walking around seemingly unconcerned about the hoof that was hanging out of her. Getting a closer look I saw not just a kid’s hoof, but also a nose and mouth. The kid’s tongue was hanging out of its mouth and clearly this was not the way it was supposed to arrive. Assuming it was an unfortunate stillborn, I  caught Fannie, pushed the kid’s head back in a little so I could reach in and find the other hoof, then pulled the kid out. He hit the ground squealing, perfectly healthy.


Fannie’s baby, after his reluctant arrival


Then yesterday morning at dawn I discovered that Carrie had kidded, another first-time Mama. Despite having warm deeply-bedded barn stalls available, she dropped the kid in the dirt, in the cold. When I found the kid she was freezing cold and barely breathing.  I brought her inside, cleaned her, and warmed her up with a blow dryer. Soon she perked up.

carrie's kid.jpg

This is how we roll on White Flint Farm


Then I caught her mother and milked some colostrum from her, which I fed the kid with an eyedropper. I locked mama and baby in a stall together and now the kid is walking around and nursing fine.

It rained all night here, with temps in the thirties. I went out twice overnight to make sure no one had kidded in the freezing rain. Luckily they hadn’t. Will be heading out again in a few minutes to check on everyone.

Hoping it goes more smoothly from here on out.

On an entirely different subject, I can’t read WordPress blogs on Internet Explorer these days. I’ve googled the problem but found nothing. Chrome works fine, but I have my bookmarks on Explorer and don’t want to transfer them to Chrome. Anyone else having this problem? Any tips for what to do about it?